Issue749

Title received SIGSEGV!
Priority release-blocker Status rejected
Assigned To Keywords
Linked issues Watchers

Submitted on 2014-06-28 14h10 by mhwombat, last changed by fluzz.

Messages
Author: mhwombat Date: 2014-06-28   14h10
I was down in the old abandoned complex, just smashing crates and barrels, when
the game crashed.

amy@mousema:~/src/freedroid/src$ ./freedroidRPG 

Hello, this is FreedroidRPG, version 0.15-1192-gfb92739.

Video system type: x11.
Using screen resolution 800 x 600.

Testing if color depth 32 bits is available... YES.

video mode set (bpp=24 RGBA=8880 depth=24)
-OpenGL--------------------------------------------------------------------------
Vendor     : Tungsten Graphics, Inc
Renderer   : Mesa DRI Intel(R) 945GM x86/MMX/SSE2
Version    : 1.4 Mesa 8.0.5
Extensions : GL_ARB_multisample GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color
GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_copy_texture
GL_EXT_polygon_offset GL_EXT_subtexture GL_EXT_texture_object
GL_EXT_vertex_array GL_EXT_compiled_vertex_array GL_EXT_texture GL_EXT_texture3D
GL_IBM_rasterpos_clip GL_ARB_point_parameters GL_EXT_draw_range_elements
GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal
GL_EXT_separate_specular_color GL_EXT_texture_edge_clamp GL_SGIS_generate_mipmap
GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod
GL_ARB_multitexture GL_IBM_multimode_draw_arrays GL_IBM_texture_mirrored_repeat
GL_3DFX_texture_compression_FXT1 GL_ARB_texture_cube_map GL_ARB_texture_env_add
GL_ARB_transpose_matrix GL_EXT_blend_func_separate GL_EXT_fog_coord
GL_EXT_multi_draw_arrays GL_EXT_secondary_color GL_EXT_texture_env_add
GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias
GL_INGR_blend_func_separate GL_NV_blend_square GL_NV_light_max_exponent
GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_SUN_multi_draw_arrays
GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_EXT_framebuffer_object
GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_MESA_window_pos
GL_NV_packed_depth_stencil GL_NV_texture_rectangle GL_NV_vertex_program
GL_ARB_depth_texture GL_ARB_shadow GL_ARB_texture_env_combine
GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3
GL_ARB_texture_mirrored_repeat GL_ARB_window_pos GL_EXT_stencil_two_side
GL_EXT_texture_cube_map GL_NV_vertex_program1_1 GL_APPLE_packed_pixels
GL_APPLE_vertex_array_object GL_ARB_draw_buffers GL_ARB_fragment_program
GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_vertex_program
GL_ARB_vertex_shader GL_ATI_draw_buffers GL_ATI_texture_env_combine3
GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_MESA_pack_invert
GL_MESA_ycbcr_texture GL_ARB_half_float_pixel GL_ARB_point_sprite
GL_ARB_shading_language_100 GL_ARB_sync GL_ARB_texture_non_power_of_two
GL_ARB_vertex_buffer_object GL_ATI_blend_equation_separate
GL_EXT_blend_equation_separate GL_OES_read_format GL_ARB_pixel_buffer_object
GL_ARB_texture_rectangle GL_EXT_pixel_buffer_object GL_EXT_texture_rectangle
GL_ARB_framebuffer_object GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample
GL_EXT_packed_depth_stencil GL_APPLE_object_purgeable GL_ARB_vertex_array_object
GL_ATI_separate_stencil GL_EXT_gpu_program_parameters GL_OES_EGL_image
GL_ARB_copy_buffer GL_ARB_map_buffer_range GL_EXT_separate_shader_objects
GL_ARB_ES2_compatibility GL_ARB_draw_elements_base_vertex
GL_ARB_explicit_attrib_location GL_ARB_provoking_vertex GL_ARB_sampler_objects
GL_EXT_provoking_vertex GL_ARB_robustness 


Now respawning all bots on level : 42. 
Now respawning all bots on level : 6. 
Now respawning all bots on level : 19. 
Now respawning all bots on level : 2. 
---------------------------------------------------------------------------------
FreedroidRPG 0.15-1192-gfb92739 encountered a problem in function: animate_blasts
A BLAST WAS FOUND TO EXIST OUTSIDE THE BOUNDS OF THE MAP.
This is an indication of an inconsistency in FreedroidRPG.

However, the error is not fatal and will be silently compensated for now.
When reporting a problem to the FreedroidRPG developers, please note if this
warning message was created prior to the error in your report.
However, it should NOT cause any serious trouble for FreedroidRPG.

The problem mentioned above is not fatal, we continue the execution.
---------------------------------------------------------------------------------

Now respawning all bots on level : 2. 
---------------------------------------------------------------------------------
FreedroidRPG 0.15-1192-gfb92739 encountered a problem in function: animate_blasts
A BLAST WAS FOUND TO EXIST OUTSIDE THE BOUNDS OF THE MAP.
This is an indication of an inconsistency in FreedroidRPG.

However, the error is not fatal and will be silently compensated for now.
When reporting a problem to the FreedroidRPG developers, please note if this
warning message was created prior to the error in your report.
However, it should NOT cause any serious trouble for FreedroidRPG.

The problem mentioned above is not fatal, we continue the execution.
---------------------------------------------------------------------------------

Now respawning all bots on level : 8. 
Now respawning all bots on level : 9. 
Now respawning all bots on level : 16. 
Now respawning all bots on level : 33. 
Now respawning all bots on level : 1. 
Now respawning all bots on level : 13. 
Now respawning all bots on level : 58. 
Now respawning all bots on level : 18. 
Now respawning all bots on level : 3. 
Now respawning all bots on level : 12. 
Now respawning all bots on level : 17. 
Now respawning all bots on level : 20. 
Now respawning all bots on level : 42. 
Now respawning all bots on level : 6. 
Now respawning all bots on level : 19. 
Now respawning all bots on level : 2. 
Now respawning all bots on level : 8. 
Now respawning all bots on level : 26. 
Now respawning all bots on level : 9. 
Now respawning all bots on level : 16. 
Now respawning all bots on level : 33. print_trace:  Obtained 9 stack frames.
print_trace:  Obtaining symbols now done.
.(print_trace+0x1c) [0x808bbdc]
[0xb7705400]
.(show_current_text_banner+0x81) [0x8096911]
.(show_texts_and_banner+0x20) [0x8097a50]
.(AssembleCombatPicture+0x6ec) [0x809e27c]
.(Game+0x56) [0x8095a86]
.(main+0x159) [0x805bb29]
/lib/i386-linux-gnu/i686/cmov/libc.so.6(__libc_start_main+0xe6) [0xb738ce46]
.() [0x805bc6d]

print_trace():  received SIGSEGV!

---------------------------------------------------------------------------------
Termination of freedroidRPG initiated... Thank you for playing freedroidRPG.

amy@mousema:~/src/freedroid/src$
Author: jesusalva Date: 2014-07-02   01h13
Hmmm...
I would ask to you run it on gdb or valgrind, but it seems to had been a random
error...

Yes, I'm also getting a lot of SIGSEGVs lately. I wonder why.

Now, about the non-fatal error:
It basicaly said that when you bashed the crate, it should had started a blast,
but it was't started correctly. In other words, for some reason it was animated
outside the map.
So, I would recommend you to stop bashing crates and barrels when this error
happens again.

I was not able to reproduce.
Author: matthiaskrgr Date: 2014-08-01   18h41
Hmm, I compiled that revision and tried to run addr2line with the stacktrace,
but I didn't get any usable results from this :/
Author: fluzz Date: 2014-09-06   21h46
Without more information, that bug can't be fixed. I can't find what could be
wrong in the current code.
History
Date User Action Args
2014-09-06 21:46:07fluzzsetstatus: open -> rejected
messages: + msg2889
2014-08-01 18:41:52matthiaskrgrsetmessages: + msg2858
2014-08-01 10:27:40Xenuxsetpriority: bug -> release-blocker
2014-07-02 01:13:35jesusalvasetmessages: + msg2834
2014-06-28 14:10:24mhwombatcreate