Title Allow more than gawk in configure script
Priority release-blocker Status resolved
Assigned To Keywords
Linked issues Watchers

Submitted on 2020-02-19 16h47 by Snark, last changed by Snark.

Author: Snark Date: 2020-02-19   16h47
I tried to package 1.0rc2 for debian experimental, but it doesn't work because freedroidRPG doesn't get installed.

I tried to go in src/ and run "make install DESTDIR=/tmp/toto", and indeed, the /tmp/toto/usr/games/ directory gets created, but nothing gets put inside!

I tried to have a look at, but didn't spot anything obvious.

I tried to start from the raw tarball,, configure --prefix=/tmp/toto, build, run "make install" in src/ : /tmp/toto/bin gets created but there's nothing inside.

So I think it's not just my packaging getting bad : there's something fishy upstream.
Author: Snark Date: 2020-02-20   06h38
Oh, found the problem : if gawk isn't found, then the configure script still ends happily, so you can go on compiling ; but when you try to install, for the install target of freedroidRPG, then there's a problem because AWK=''. But that error doesn't make "make" unhappy either! So you end up with a failed install, even though there's no reported error. You have to check in the logs to find out about it.

For the Debian package, I'll apply change the following line:
AC_PATH_PROG([AWK], [gawk], [])    dnl GNU version of awk awk is needed in some po/ scripts

AC_PATH_PROGS([AWK], [gawk mawk], [])

I haven't seen the problem with mawk and the po/ scripts...
Author: Snark Date: 2020-02-20   06h40
(Notice that I don't fix the problem with erroring out of the configure script if no awk is found - I just make so it finds more often what is needed)
Author: Snark Date: 2020-02-20   06h41
Oh, I just see that it's a duplicate of #868 : rejecting my own report!
Date User Action Args
2020-02-20 15:04:30Snarksetstatus: open -> resolved
2020-02-20 06:41:47Snarksetmessages: + msg3669
2020-02-20 06:40:11Snarksetmessages: + msg3668
2020-02-20 06:39:13Snarksettitle: 1.0rc2 doesn't install /usr/games/freedroidRPG -> Allow more than gawk in configure script
2020-02-20 06:38:52Snarksetmessages: + msg3667
2020-02-19 16:47:16Snarkcreate