Title ASAN crash while reloading savegame.
Priority release-blocker Status resolved
Assigned To fluzz Keywords
Linked issues Watchers fluzz

Submitted on 2013-09-19 13h58 by matthiaskrgr, last changed by fluzz.

Author: matthiaskrgr Date: 2013-09-19   13h58
Was in the tutorial, tried to load previous or backup (don't remember) savegame
and it crashed:

INFO: AddressSanitizer ignores mlock/mlockall/munlock/munlockall
==12717== ERROR: AddressSanitizer: attempting free on address which was not
malloc()-ed: 0x6036001da940
    #0 0x7fec3e02f47a (/usr/lib/
    #1 0x7fec3d02ea98 (/usr/lib/
0x6036001da940 is located 0 bytes inside of 22-byte region
==12717== AddressSanitizer CHECK failed:
"((tid < n_threads_)) != (0)" (0x0, 0x0)
    #0 0x7fec3e02c44d (/usr/lib/
    #1 0x7fec3e033283 (/usr/lib/
    #2 0x7fec3e02d9f8 (/usr/lib/
    #3 0x7fec3e030f51 (/usr/lib/
    #4 0x7fec3e031883 (/usr/lib/
    #5 0x7fec3e022b3f (/usr/lib/
    #6 0x7fec3e02f4a7 (/usr/lib/
    #7 0x7fec3d02ea98 (/usr/lib/
    #8 0x7fec3d02613c (/usr/lib/
    #9 0x7fec3d02a0cf (/usr/lib/
    #10 0x7fec3d02321f (/usr/lib/
    #11 0x7fec3d0248d1 (/usr/lib/
    #12 0x7fec3d029c9d (/usr/lib/
    #13 0x44851b (/home/matthias/vcs/git/freedroid/src/freedroidRPG+0x44851b)
    #14 0x437490 (/home/matthias/vcs/git/freedroid/src/freedroidRPG+0x437490)
    #15 0x41a084 (/home/matthias/vcs/git/freedroid/src/freedroidRPG+0x41a084)
    #16 0x41bd83 (/home/matthias/vcs/git/freedroid/src/freedroidRPG+0x41bd83)
    #17 0x41e1fd (/home/matthias/vcs/git/freedroid/src/freedroidRPG+0x41e1fd)
    #18 0x4ac769 (/home/matthias/vcs/git/freedroid/src/freedroidRPG+0x4ac769)
    #19 0x4accb5 (/home/matthias/vcs/git/freedroid/src/freedroidRPG+0x4accb5)
    #20 0x4a8b57 (/home/matthias/vcs/git/freedroid/src/freedroidRPG+0x4a8b57)
    #21 0x4ae6e6 (/home/matthias/vcs/git/freedroid/src/freedroidRPG+0x4ae6e6)
    #22 0x415c99 (/home/matthias/vcs/git/freedroid/src/freedroidRPG+0x415c99)
    #23 0x7fec3c577bc4 (/usr/lib/
    #24 0x41644c (/home/matthias/vcs/git/freedroid/src/freedroidRPG+0x41644c)

addr2line -e ./src/freedroidRPG 0x44851b 0x437490 0x41a084 0x41bd83 0x41e1fd
0x4ac769 0x4accb5 0x4a8b57 0x4ae6e6 0x415c99 0x41644c     matthias@t400 99.9

c6c1c71f24d429e55afec847f59a177f179656d4 + soft code changes
Author: jesusalva Date: 2014-08-30   14h44
It's saying that somewhere on the code there was a free() call but whatever it
tried to free was not yet allocated w/ malloc().

It also printed the memory address so any pro-mega-ultra-expert on FDRPG code
can locate which memory address (variable) you tried to free.

Please make also sure that the backup/latest was not from an old commit of
FDRPG! In this case it's very possible to happen: Although I would expect worse,
I admit.

BTW, can you reproduce the bug at any time? Can you save the game again? Can you
load the latest saved game after you save the game again? etc etc etc...
Author: fluzz Date: 2014-09-08   16h25
This was fixed in b1a73aebeba (Oct. 16 2013).
We forgot to close the ticket at that time.
Date User Action Args
2014-09-08 16:25:09fluzzsetstatus: open -> resolved
assignedto: fluzz
messages: + msg2891
nosy: + fluzz
2014-08-30 14:44:59jesusalvasetmessages: + msg2878
2014-08-29 15:22:32Xenuxsetpriority: important -> release-blocker
2013-09-19 13:58:57matthiaskrgrcreate