Title Loading: Cannot load saved characters - program closes
Priority 0.16 rc bugs Status resolved
Assigned To fluzz Keywords
Linked issues Quest/Notes screen doesn't display properly
View: 836
Watchers fluzz

Submitted on 2015-09-27 03h35 by Ty-Guy6, last changed by Ty-Guy6.

Author: Ty-Guy6 Date: 2015-09-27   03h35
I have saved my game at several points, but loading either by "Load Existing
Hero" or by either Game Over option, only closes the program. It says "Loading"
in the game for five seconds, then the window disappears and doesn't return.

However, when I load the single most recent of my saved characters from the
startup menus, instead of just closing the program, I get this message: 

"An error occurred while trying to load the savegame. A data type was found to
be incompatible with the expected one. Your savegame could be corrupted and so
its loading is aborted. If you see this message and you have not manually
modified your savegame, ma.." (The message is cut short, apparently, but I can
click out of it to the menus again.)

I have not touched the savegame files. As a sidenote, I got a different error
when I first tried loading a saved game before I had made any.

I am using Windows, downloaded the game (latest version) on 9/26/15.

Related?: My Quest/Notes screens also aren't working. See linked issue.
Author: fluzz Date: 2015-09-27   17h49
My guess is that you use 0.16 rc1.

What you describe is expected to be solved in RC2.

Could you please download and try

RC2 can possibly also fix issue836.

That version is not on the ftp server, because we still have some issues on Win10.

Thx for your report.
Author: Ty-Guy6 Date: 2015-09-29   05h43
Yes, I was using 0.16 rc1. I'll try to get back with a test of rc2 in a day or
so, for these two issues.

On the plus side, playing through the game while knowing there was no save WAS a
hardcore mode to start off in. Reminded me of "Don't Starve", with its
dynamic. I may just go for broke with it even without the save -- see if I can
beat the game in one go! (Maybe just save so I don't lose game to computer
Author: Ty-Guy6 Date: 2015-09-30   06h28
Ok, fluzz, you are correct: both the quest/notes display and the save/load
character functionality seem to be working in the later version. I'll go ahead
and mark these two issues as Resolved. Thanks for the help!
Date User Action Args
2015-09-30 06:29:01Ty-Guy6setstatus: open -> resolved
2015-09-30 06:28:55Ty-Guy6setmessages: + msg3247
2015-09-29 05:43:05Ty-Guy6setmessages: + msg3246
2015-09-27 17:49:58fluzzsetpriority: important -> 0.16 rc bugs
assignedto: fluzz
messages: + msg3243
nosy: + fluzz
2015-09-27 03:35:30Ty-Guy6create