Title Reproducable SIGFPE
Priority release-blocker Status resolved
Assigned To fluzz Keywords
Linked issues SIGSEGV in access tunnel for shield control
View: 454
Watchers fluzz

Submitted on 2012-02-25 21h36 by tokei, last changed by fluzz.

File name Uploaded Type Edit Remove
flump.sav.gz tokei, 2012-02-25.21:36:37 application/gzip
flump.shp tokei, 2012-02-25.21:37:42 application/octet-stream
flump.shp_fixed matthiaskrgr, 2012-02-25.22:54:54 application/octet-stream
map-to-crash.png tokei, 2012-02-25.22:05:06 image/png
seg-fault-and-sigfpe tokei, 2012-02-25.21:40:09 application/octet-stream
sigfpe-debug-5 tokei, 2012-02-25.21:42:41 application/octet-stream
Author: tokei Date: 2012-02-25   21h36
I'm running freedroidRPG 0.15 on Arch Linux. After playing for a few weeks now,
the game suddenly crashes within minutes of playing. There where a few Arch
updates during that time so something on my system might have changed but I
don't have further details about which packages where affected.

The game first crashed with an underrun and a subsequent seg fault in ALSAs lib
pcm.c. I tried to play with --nosound which seemed to fix that problem at first
but now the game crashes reproducable with a SIGFPE. There seems to be no
specific location involved other that I'm currently trying to master the
Disruptor Tunnel.

I'm attaching the save game and a few logs. Please tell me, what other
information would help you.

Attached flump.sav.gz.
Author: tokei Date: 2012-02-25   21h37
The other save game file. Not sure if both are needed.

Attached flump.shp.
Author: tokei Date: 2012-02-25   21h40
Log of the seg fault and the SIGFPE.
Author: tokei Date: 2012-02-25   21h42
Rather extensive log of the SIGFPE with
  freedroidRPG --nosound --debug=5

Attached sigfpe-debug-5.
Author: matthiaskrgr Date: 2012-02-25   21h50
I maintain the freedroidrpg-svn aur package.

Is the problem reproducible when you have the aur package installed?
Author: tokei Date: 2012-02-25   22h05
I tried to make a backtrace as described on, but I'm not sure
this is helping. I'm not familiar with gdb or C(++).

...lots of those...
[New Thread 0xb4f99b40 (LWP 32176)]
[Thread 0xb4f99b40 (LWP 32176) exited]
[New Thread 0xb4f99b40 (LWP 32177)]
[Thread 0xb4f99b40 (LWP 32177) exited]

Program received signal SIGFPE, Arithmetic exception.
0x080a14f8 in update_light_list ()
(gdb) bt full
#0  0x080a14f8 in update_light_list ()
No symbol table info available.
#1  0x08099f2b in AssembleCombatPicture ()
No symbol table info available.
#2  0x08091df6 in Game ()
No symbol table info available.
#3  0x08059961 in main ()
No symbol table info available.

I'm now reasonably sure that this bug can be reproduced by moving south as far
as possible and then east through the corridor. At the end of the corridor, the
game crashes. (see map ;)

Attached map-to-crash.png.
Author: matthiaskrgr Date: 2012-02-25   22h18
Ok, I can reproduce this problem with the aur package as well.

I assume that you are affected by this bug:
Author: matthiaskrgr Date: 2012-02-25   22h25
Ok, I think I can fix your savegame manually. :)
Author: matthiaskrgr Date: 2012-02-25   22h25
(so you'll be able to continue playing with 0.15, if the bug doesn't happen to
the savegame again)
Author: tokei Date: 2012-02-25   22h49
I've tried to install the aur package, but for some reason I don't understand,
this fails. 

==> Compiling done.
==> Tidying install...
  -> Purging unwanted files...
  -> Compressing man and info pages...
  -> Stripping unneeded symbols from binaries and libraries...
==> Creating package...
  -> Generating .PKGINFO file...
  -> Adding changelog file...
  -> Compressing package...
xz: (stdout): Write error: No space left on device
bsdtar: Write error
==> ERROR: Failed to create package file.

I'm not sure what device that would be, since there are 20 gig left on my hdd.
But anyways, since you reproduced the bug already, it doesn't matter.

If you could fix the save game, that would be great! I realy enjoy playing :)
Maybe you could write up some short howto so I can fix it myself if this happens

Thank you and all involved so very much for this great game and the great support!
Author: matthiaskrgr Date: 2012-02-25   22h53
>I'm not sure what device that would be, since there are 20 gig left on my hdd.

If you use  yaourt -S foo   on an aur package this will use /tmp as directory
where the package is build.  Maybe your tmp is not big enough.

When you download the zip from the aur page, extract it and run "makepkg" in its
dir, (and pacman/yaourt -U ./freedroidRPG-svn... afterwards) this should work.
Author: matthiaskrgr Date: 2012-02-25   22h54
Here is the new .shp  file, I hope I didn't change too many things, you'll
notice some strange crates as you walk down the corridor, just ignore and/or
smash them. :)

Good luck and have fun!

Attached flump.shp_fixed.
Author: tokei Date: 2012-02-25   23h09
You are awesome! Thank you very much! It's working again. You were - of course -
also right about /tmp not being big enough. Thank you again and have a nice evening.
Author: matthiaskrgr Date: 2012-02-25   23h11

If it crashes again, just tell me what level it crashed on and drop the .shp
here again. :)
Author: ahuillet Date: 2012-02-26   12h12

so this is the second time we are affected by this bug in 0.15, correct? We
really need to release .15.1...
Author: fluzz Date: 2012-02-26   12h17
On 02/26/2012 01:12 PM, Arthur Huillet - Roundup wrote:
> Arthur Huillet<>  added the comment:
> Hello,
> so this is the second time we are affected by this bug in 0.15, correct? We
> really need to release .15.1...


And to be able to more easily create the packages, we should officially 
switch to git...

> ----------
> assignedto:  ->  fluzz
> nosy: +fluzz
> ________________________________________
> FreedroidRPG issues<>
> <>
> ________________________________________
Author: Xenux Date: 2014-08-07   21h29
fluzz can check it's fixed please
Author: fluzz Date: 2014-09-04   21h41
This bug was fixed. See issue 454.
Date User Action Args
2014-09-04 21:41:00fluzzsetstatus: open -> resolved
messages: + msg2885
2014-08-07 21:29:05Xenuxsetpriority: bug -> release-blocker
messages: + msg2862
2012-02-26 12:17:03fluzzsetmessages: + msg2176
2012-02-26 12:12:25ahuilletsetassignedto: fluzz
messages: + msg2175
nosy: + fluzz
2012-02-25 23:11:29matthiaskrgrsetmessages: + msg2174
2012-02-25 23:09:22tokeisetmessages: + msg2173
2012-02-25 22:54:54matthiaskrgrsetfiles: + flump.shp_fixed
messages: + msg2172
2012-02-25 22:53:39matthiaskrgrsetmessages: + msg2171
2012-02-25 22:49:59tokeisetmessages: + msg2170
2012-02-25 22:25:55matthiaskrgrsetmessages: + msg2169
2012-02-25 22:25:04matthiaskrgrsetmessages: + msg2168
2012-02-25 22:18:53matthiaskrgrsetmessages: + msg2167
linked: + SIGSEGV in access tunnel for shield control
2012-02-25 22:05:06tokeisetfiles: + map-to-crash.png
messages: + msg2166
2012-02-25 21:50:28matthiaskrgrsetmessages: + msg2165
2012-02-25 21:42:41tokeisetfiles: + sigfpe-debug-5
messages: + msg2164
2012-02-25 21:40:09tokeisetfiles: + seg-fault-and-sigfpe
messages: + msg2163
2012-02-25 21:37:43tokeisetfiles: + flump.shp
messages: + msg2162
2012-02-25 21:36:37tokeicreate