Title Restricted window frame for cursor in-game
Priority release-blocker Status rejected
Assigned To fdadmin Keywords dialog, graphics
Linked issues Watchers fdadmin

Submitted on 2012-08-17 01h14 by MetropolitanVickers, last changed by fluzz.

Author: MetropolitanVickers Date: 2012-08-17   01h14
When I start a new game the cursor works just fine; but when I start a 
conversation with some NPC then the cursor gets trapped inside a "window" that is 
smaller than the game screen. I can't select the icons for log, items, etc, or 
check my health or temperature.
Author: hakzsam Date: 2012-08-17   09h19
What is your version of freedroid?
Author: MetropolitanVickers Date: 2012-08-18   19h14
0.14.1-1, installed on Ubuntu 12.04 via deb package. I tried the latest version 
too, and the problem persists.
Author: MetropolitanVickers Date: 2012-08-18   19h18
And let me correct what I said before: the problem appears in the entire game, 
and just after the initial loading screen. But sometimes when I start the 
program, I don't know why, the problem is gone until I open a dialog.
Author: MetropolitanVickers Date: 2012-08-21   02h11
Update: I installed Xubuntu on my notebook, re-installed the game and now 
everything works fine. Could be a problem with the Unity interface?
Author: fluzz Date: 2013-10-08   14h37
On 08/18/2012 09:18 PM, Ariel Sebastian Becker - Roundup wrote:
> Ariel Sebastian Becker<>  added the comment:
> And let me correct what I said before: the problem appears in the entire game,
> and just after the initial loading screen. But sometimes when I start the
> program, I don't know why, the problem is gone until I open a dialog.

Are you running the game in fullscreen ?
Do you have the same issue in windowed mode ?

You are using Unity, right ? Any way to test the game with an other
window-manager (gnome-shell, kde, mate, lxde...) ?

> ________________________________________
> FreedroidRPG issues<>
> <>
> ________________________________________
> ------------------------------------------------------------------------------
> Live Security Virtual Conference
> Exclusive live event will cover all the ways today's security and
> threat landscape has changed and how IT managers can respond. Discussions
> will include endpoint security, mobile security and the latest in malware
> threats.
> _______________________________________________
> Freedroid-bugs mailing list
Author: fluzz Date: 2013-10-08   14h37
On 08/21/2012 04:11 AM, Ariel Sebastian Becker - Roundup wrote:
> Ariel Sebastian Becker <> added the comment:
> Update: I installed Xubuntu on my notebook, re-installed the game and now
> everything works fine. Could be a problem with the Unity interface?

Could indeed be.

I'm afraid none of the devs run Unity, so we are not currently able to 
reproduce the bug that you reported.

Perhaps someone (matthias ???) could check it in a VM running the last
Ubuntu release ?
Author: matthiaskrgr Date: 2013-10-08   21h38
I don't have anything like vm or ubuntu on my machine, sorry.
Author: Xenux Date: 2013-10-18   09h29
I have ubuntu with unity but it's not a pure unity. I have installed xfce. However 
I will check it tonight.
Author: Xenux Date: 2013-10-18   23h28
I tested on my ubuntu 12.04 with unity and I have got no problem.
Author: jesusalva Date: 2014-08-12   01h53
I got this problem a lot when I played on windowed mode. I usually only noticed
it because I couldn't click on 'scroll down' button on the dialog mode.

This error was present on 0.14 and if I'm not mistaken on 0.15 as well. I use
gnome, but my other netbook runs unity. They all are ubuntu 12.04.

Strangely, after using git version I didn't saw anymore this bug. Not that I
could get they to often, the massive dialogs which used to force me to try to
press that button are long gone.
Author: fluzz Date: 2015-03-10   18h43
Is someone still having this bug ? If not, I'll close the ticket.
Author: digifuzzy Date: 2015-04-13   03h05
Maybe create a VM w/[xu|u]buntu to verify issue.
Author: digifuzzy Date: 2015-04-13   12h11
Using VirtualBox (4.3.18_Gentoo) w/ Xubuntu 14.04 (3.16.0-34-generic
#45~14.04.1-Ubuntu SMP)

In "window" mode - no problems were observed in game play.
In "full screen" - cursor was uncontrollable with mouse but input to keys was
Do not believe issue is related to VM. Will double check as well as verify with
git version.
Author: jesusalva Date: 2015-04-13   13h25
The cursor speed must be slowed to play 
most of games which resize your 
resolution, instead of themselves.
Eg. Instead of resizing to 1280×768, it 
resizes your screen to 800×600.

Not sure if this is the case.
Author: digifuzzy Date: 2015-04-13   14h08
Window Size 1280x768 - Resolution was fine.
No "resizing" involved.
Author: jesusalva Date: 2015-04-13   16h58
Not sure if you understood my comment... 
which was hard to understand anyway.
Play FreeDink on fullscreen and you'll 
understand. Specially if the game crash 
and you see your monitor resolution set 
to 640×480.
Author: digifuzzy Date: 2015-04-13   20h36
I understood your comment perfectly. I did not encounter what you are
describing. FreedroidRPG resolution is configurable both from the game
menu(options->graphics - restart required) or from the command line (-r99).

And what does this have to do with loss of cursor movement?
Author: digifuzzy Date: 2015-04-15   04h49
Issue with full screen and mouse cursor problem.
Found link:

Confirm that starting FDRPG w/
"SDL_MOUSE_RELATIVE=0 freedroidRPG -f -rX" (where x is 1 of available resolutions)
The cursor responds normally in full screen mode (acts the same as window mode).

Now to dig into the bug...
Author: digifuzzy Date: 2015-04-16   09h11
After updating xubuntu environment to latest (including installing latest mesa),
problem was not observed in 0.15.1 in either full screen or window mode.

OP originally sited problem was with previous revision but was not present in
current release. Unable to duplicate bug with latest release in xubuntu VM

Recommend close.
Author: jesusalva Date: 2015-04-16   14h51
This bug did happened with me at Ubuntu 
12.04 on FDRPG 0.15.1, but didn't at the 
last version I used,on same environment.

Recommend closing as well, but there are 
still chances that we hear about this bug 
Author: fluzz Date: 2015-04-28   20h22
Since nobody seems able to really reproduce and give a more precise symptom, I
close the ticket.
Date User Action Args
2015-04-28 20:22:22fluzzsetstatus: open -> rejected
messages: + msg3142
2015-04-16 14:51:41jesusalvasetmessages: + msg3123
2015-04-16 09:11:20digifuzzysetmessages: + msg3122
2015-04-15 04:49:11digifuzzysetmessages: + msg3116
2015-04-13 20:36:05digifuzzysetmessages: + msg3113
2015-04-13 16:58:38jesusalvasetmessages: + msg3112
2015-04-13 14:08:28digifuzzysetmessages: + msg3111
2015-04-13 13:25:58jesusalvasetmessages: + msg3110
2015-04-13 12:11:12digifuzzysetmessages: + msg3108
2015-04-13 03:05:18digifuzzysetmessages: + msg3106
2015-03-10 18:43:25fluzzsetmessages: + msg3086
2014-08-12 01:53:21jesusalvasetmessages: + msg2868
2014-08-01 10:37:36Xenuxsetpriority: bug -> release-blocker
2013-10-18 23:28:23Xenuxsetmessages: + msg2619
2013-10-18 09:29:39Xenuxsetmessages: + msg2615
2013-10-08 21:38:50matthiaskrgrsetmessages: + msg2610
2013-10-08 14:37:05fluzzsetmessages: + msg2603
2013-10-08 14:37:04fluzzsetmessages: + msg2602
2012-08-21 02:11:13MetropolitanVickerssetmessages: + msg2330
2012-08-18 19:18:34MetropolitanVickerssetmessages: + msg2329
2012-08-18 19:14:26MetropolitanVickerssetmessages: + msg2328
2012-08-17 09:19:54hakzsamsetmessages: + msg2327
2012-08-17 01:14:59MetropolitanVickerscreate